Widespread Certificate Error

This is issue is now resolved.


This Saturday, a root security certificate at our provider InCommon expired. This has created an unexpected number of ripple issues for web-based services at many institutions, including Brown. This can include unpredictable login and functionality errors on multiple services, including department servers in some cases.

Many core/critical services at Brown were resolved on Saturday, but we continue to work on additional services today.

We will be sharing more information as it's available. Please keep an eye on https://it.brown.edu/alerts/read/widespread-certificate-error, we will update it with any new information.

 

General Alert
Resolved

Written by jemsmith@brown.edu on