Mandatory Zoom Update - May 30th

The following is a legitimate notification of a Zoom update scheduled for May 30th and announced in Today@brown on May 20th. You can read more in this IT KnowledgeBase article Keeping Your Zoom Client Updated.


From: Zoom Video Communications <no-reply@zoom.us>
Date: Fri, May 29, 2020 at 9:25 AM
Subject: Mandatory Zoom Update - May 30th
To: <josiah_carberry@brown.edu>

Dear Valued Customer,

As we have previously communicated, beginning May 30th, 2020, Zoom will be enabling GCM encryption across the entire Zoom platform, providing increased protection for meeting data.

Please update all your clients to Zoom 5.0 now or before May 30th.

After May 30, 2020, in order to join a Zoom meeting you are required to be on Zoom 5.0 or higher. If you have not updated your desktop or mobile client, you will have the choice to update or join via a browser.

[ Update Now ]

Please refer here for more information on updating your endpoints.

For further instructions on updating your Zoom client and how to view your Zoom version number please visit our Knowledge Center.

Best,
The Zoom Team


Screen shot of Zoom notification

Phishing
Legitimate Email

Written by pfalcon@brown.edu on